Press "Enter" to skip to content

Does a multicast source have to be connected to the RP for Cisco PIM-SM to work?

Last updated on January 5, 2019

        I'm fairly new to networking in general, but I need to develop a 4 point mesh with redundant paths routing multicast from point A to points B and C. I've already setup the mesh and have network redistribution with OSPF and PIM-SM running and working (99% anyways... I think), however, I'm having a issue where if a source is connected to any router that is not the RP (where the RP is also the gateway for the source) the multicast is not being distributed.
As I understand it, the router receiving the multicast should be either notifying the RP that he has the source for that group so the RP can build the SPT or should be unicasting the stream to the RP for it's redistribution, but there's no traffic going from this router towards the RP. In my lab, I'm using 4x catalyst 3550 switches with the EMI firmware to enable the multicast routing. I've set it up using the autorp feature (I only intend to have a single RP) in case we later on decide to add more redundancy to the design. Is there anything I need to do on the non-rp router to tell him "if you see this multicast IP originating within one of your networks relay it to the RP" or should this be happening on its own? RP:
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PT
!
no logging console
!
username EDITED privilege 15 secret 5 EDITED
aaa new-model
!
!
!
!
!
aaa session-id common
ip subnet-zero
ip routing
no ip domain-lookup
!
!
ip multicast-routing
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
ip ssh version 2
!
!
!
!
!
interface Loopback0
 ip address 172.30.255.0 255.255.255.255
 ip pim sparse-mode
!
interface FastEthernet0/1
 description CNMG
 no switchport
 ip address 172.30.2.1 255.255.255.252
 ip pim sparse-mode
 ip ospf cost 100
 load-interval 30
!
!
interface FastEthernet0/3
 description TT
 no switchport
 ip address 172.30.2.17 255.255.255.252
 ip pim sparse-mode
 ip ospf cost 1000
 load-interval 30
!
!
!
interface FastEthernet0/24
 description WinPC_Server_Source
 switchport access vlan 2
 switchport mode access
 load-interval 30
 spanning-tree portfast
!
interface GigabitEthernet0/1
 switchport mode dynamic desirable
!
interface GigabitEthernet0/2
 switchport mode dynamic desirable
!
interface Vlan1
 ip address 192.168.20.254 255.255.255.0
!
interface Vlan2
 ip address 172.30.100.6 255.255.255.248
 ip pim sparse-mode
!
router ospf 100
 log-adjacency-changes
 redistribute connected metric-type 1 subnets
 network 172.30.2.0 0.0.0.3 area 0
 network 172.30.2.16 0.0.0.3 area 0
!
ip default-gateway 172.30.0.254
ip classless
ip http server
ip http secure-server
!
ip pim autorp listener
ip pim send-rp-announce Loopback0 scope 12 group-list 1
ip pim send-rp-discovery scope 12
!
access-list 1 permit 239.10.10.0 0.0.0.255
!
control-plane
!
!
line con 0
line vty 0 4
 privilege level 15
line vty 5 15
!
end
Source:
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec localtime show-timezone
no service password-encryption
!
hostname Cumberland
!
no logging console
!
username EDITED secret 5 EDITED
aaa new-model
!
!
!
!
!
aaa session-id common
clock timezone POS -4
ip subnet-zero
ip routing
no ip domain-lookup
!
!
ip multicast-routing
no ip igmp snooping
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
interface Loopback0
 ip address 172.30.255.2 255.255.255.255
!
interface FastEthernet0/1
 description TT
 no switchport
 ip address 172.30.2.10 255.255.255.252
 ip pim sparse-mode
 ip ospf cost 200
 load-interval 30
!
interface FastEthernet0/2
 description CNMG
 no switchport
 ip address 172.30.2.5 255.255.255.252
 ip pim sparse-mode
 ip ospf cost 100
 load-interval 30
!
! int 3-47 not in use
!
interface FastEthernet0/48
 switchport access vlan 2
 switchport mode access
 load-interval 30
 spanning-tree portfast
!
interface GigabitEthernet0/1
 switchport mode dynamic desirable
!
interface GigabitEthernet0/2
 switchport mode dynamic desirable
!
interface Vlan1
 ip address 192.168.22.254 255.255.255.0
!
interface Vlan2
 ip address 172.30.100.22 255.255.255.248
 ip pim sparse-mode
!
router ospf 100
 log-adjacency-changes
 redistribute connected metric-type 1 subnets
 network 172.30.2.4 0.0.0.3 area 0
 network 172.30.2.8 0.0.0.3 area 0
!
ip classless
ip http server
ip http secure-server
!
ip pim autorp listener
ip pim send-rp-discovery scope 12
!
!
control-plane
!
!
line con 0
line vty 0 4
 privilege level 15
line vty 5 15
!
end
UPDATE: Here's a diagram describing my topology: Topology Diagram UPDATE #2: I'm adding the show data requested by Ron in the comments:
Cumberland>show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.10.10.1), 2d02h/stopped, RP 172.30.255.0, flags: SJC
  Incoming interface: FastEthernet0/2, RPF nbr 172.30.2.6
  Outgoing interface list:
    Vlan2, Forward/Sparse, 2d02h/00:02:45, H

(172.30.100.5, 239.10.10.1), 2d02h/00:02:59, flags: JT
  Incoming interface: FastEthernet0/2, RPF nbr 172.30.2.6
  Outgoing interface list:
    Vlan2, Forward/Sparse, 2d02h/00:02:45, H

(*, 224.0.1.39), 2d02h/stopped, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Vlan2, Forward/Sparse, 2d02h/00:00:00
    FastEthernet0/2, Forward/Sparse, 2d02h/00:00:00
    FastEthernet0/1, Forward/Sparse, 2d02h/00:00:00

(172.30.255.0, 224.0.1.39), 2d02h/00:02:48, flags: LT
  Incoming interface: FastEthernet0/2, RPF nbr 172.30.2.6
  Outgoing interface list:
    FastEthernet0/1, Prune/Sparse, 00:02:14/00:00:45
    Vlan2, Forward/Sparse, 2d02h/00:00:00

(*, 224.0.1.40), 2d02h/stopped, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/2, Forward/Sparse, 2d02h/00:00:00
    FastEthernet0/1, Forward/Sparse, 2d02h/00:00:00
    Vlan2, Forward/Sparse, 2d02h/00:00:00

(172.30.2.10, 224.0.1.40), 00:01:37/00:01:22, flags: L
  Incoming interface: FastEthernet0/1, RPF nbr 0.0.0.0
  Outgoing interface list:
    Vlan2, Forward/Sparse, 00:01:37/00:00:00
    FastEthernet0/2, Forward/Sparse, 00:01:37/00:00:00

(172.30.2.5, 224.0.1.40), 00:01:37/00:01:22, flags: L
  Incoming interface: FastEthernet0/2, RPF nbr 0.0.0.0
  Outgoing interface list:
    Vlan2, Forward/Sparse, 00:01:37/00:00:00
    FastEthernet0/1, Forward/Sparse, 00:01:37/00:00:00

(172.30.2.17, 224.0.1.40), 2d02h/00:02:16, flags: LT
  Incoming interface: FastEthernet0/1, RPF nbr 172.30.2.9
  Outgoing interface list:
    Vlan2, Forward/Sparse, 2d02h/00:00:00
    FastEthernet0/2, Prune/Sparse, 00:01:50/00:01:09

(172.30.2.1, 224.0.1.40), 2d02h/00:02:16, flags: LT
  Incoming interface: FastEthernet0/2, RPF nbr 172.30.2.6
  Outgoing interface list:
    FastEthernet0/1, Forward/Sparse, 2d02h/00:00:00
    Vlan2, Forward/Sparse, 2d02h/00:00:00

Cumberland>sh ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
172.30.2.9        FastEthernet0/1          2d02h/00:01:42    v2    1 / S P
172.30.2.6        FastEthernet0/2          2d02h/00:01:16    v2    1 / DR S P
Cumberland>sh ip pim rp map
PIM Group-to-RP Mappings
This system is an RP-mapping agent

Group(s) 239.10.10.0/24
  RP 172.30.255.0 (?), v2v1
    Info source: 172.30.255.0 (?), elected via Auto-RP
         Uptime: 2d02h, expires: 00:02:14
Cumberland>

Be First to Comment

Leave a Reply

%d bloggers like this: