Press "Enter" to skip to content

VLAN with PAT cannot get past router

Last updated on December 23, 2018

        I'd like to start off saying that I'm out of my scope here, but I could really use some help. Our ISP gave us the following to connect to our business class internet services.
  • Network: 97.105.48.72
  • Gateway: 97.105.48.73
  • Useable: 97.105.48.74 thru 97.105.48.78
  • Broadcast: 97.105.48.79
  • Size: /29
  • Subnet: 255.255.255.248
  • TWC DNS1: 209.18.47.61
  • TWC DNS2: 209.18.47.62
I'm using a Cisco 3845 running IOS 12.4(13r). I have the switch ports on VLAN 10 getting served DHCP addresses from the router. That part seems to work fine. I have the connection from the ISP going into GigabitEthernet0/1, assigned 97.105.48.74. I'm able to ping out to the internet from the router. I tried to set up PAT from VLAN 10 to GigabitEthernet0/1. This is where things fall apart. End devices can ping 97.105.48.74, but not the ISP gateway or anything beyond. Could someone check out my config and let me know if they can spot any obvious errors? I'd really appreciate the help and I expect that my error is a simple one due to ignorance. Thank you very much.
=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2016.05.12 12:56:43 =~=~=~=~=~=~=~=~=~=~=~=

TWC-Router#sho run
Building configuration...


Current configuration : 3005 bytes
!
! Last configuration change at 06:24:57 UTC Mon May 2 2016
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname TWC-Router
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$6nZJ$MHOdhhnr7fGeq2PvctzPI.
enable password 45rtfgvb$%RTFGVB
!
no aaa new-model
!
no network-clock-participate slot 2 
!
dot11 syslog
ip source-route
no ip routing
!
no ip cef
!
!
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.1.1 192.168.1.20
!
ip dhcp pool twc-iamd
 network 192.168.1.0 255.255.255.0
 dns-server 209.18.47.61 209.18.47.62 
 default-router 192.168.1.1 
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
voice-card 0
!
!
!
!
!
!
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO3845-MB sn FOC12393HAM
!
redundancy
!
!
cem 2/0/0
 payload-size 32
!
cem 2/1/0
 payload-size 32
!
cem 2/2/0
 payload-size 32
!
cem 2/3/0
 payload-size 32
!
! 
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
 media-type rj45
!
 interface GigabitEthernet0/1
 ip address 97.105.48.74 255.255.255.248
 ip nat outside
 ip virtual-reassembly in
 no ip route-cache
 duplex auto
 speed auto
 media-type rj45
!
interface Serial0/0/0
 no ip address
 no ip route-cache
 shutdown
 clock rate 2000000
!
interface Serial0/0/1
 no ip address
 no ip route-cache
 shutdown
 clock rate 2000000
!
interface Serial0/1/0
 no ip address
 no ip route-cache
 shutdown
 clock rate 2000000
!
interface Serial0/1/1
 no ip address
 no ip route-cache
 shutdown
 clock rate 2000000
!
interface FastEthernet1/0
 switchport access vlan 10
 no ip address
!
interface FastEthernet1/1
 no ip address
 shutdown
!
interface FastEthernet1/2
 no ip address
!
interface FastEthernet1/3
 no ip address
!
interface FastEthernet1/4
 no ip address
!
interface FastEthernet1/5
 no ip address
!
interface FastEthernet1/6
 no ip address
!
interface FastEthernet1/7
 no ip address
!
interface FastEthernet1/8
 no ip address
!
interface FastEthernet1/9
 no ip address
!
interface FastEthernet1/10
 no ip address
!
interface FastEthernet1/11
no ip address
!
interface FastEthernet1/12
 no ip address
!
interface FastEthernet1/13
 no ip address
!
interface FastEthernet1/14
 no ip address
!
interface FastEthernet1/15
 no ip address
 no mop enabled
!
interface GigabitEthernet1/0
 no ip address
 shutdown
!
interface Vlan10
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
ip default-gateway 97.105.48.73
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface GigabitEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 97.105.48.73
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
!
!
!
snmp-server community public RO
!
!
control-plane
!
!
!
!
mgcp profile default
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 password 45rtfgvb$%RTFGVB
 login
 transport input all
!
scheduler allocate 20000 1000
end

TWC-Router#

Be First to Comment

Leave a Reply

%d bloggers like this: